
CwGet verze 2.37 
 

 

Obsah 
Úvodem ................................................................................................................................................... 1 

Instalace .................................................................................................................................................. 1 

Připojení zvukové karty s přijímačem ...................................................................................................... 1 

Přehled a ovládání programu .................................................................................................................. 2 

 

Úvodem 

Program pro dekódování morse kódu (CW) přes zvukovou kartu do textu. Může pracovat také jako 

úzkopásmový zvukový filtr DSP a není vyžadován žádný další hardware – potřebujete pouze přijímač a 

počítač se zvukovou kartou. Lze ho integrovat se staničním deníkem AALog. Protože pro spolupráci 

s transceiverem používá známý software Omni-Rig, Je to software dekodér morse, který opravdu fun-

guje! Program je napsán v C++ Builder, je označen jako shareware a poplatek činí jednorázově 10€, 

který lze uhradit i v českých korunách pomocí platební karty. Je určen pro operační systémy Windows 

9x/NT/2000/XP/Vista/7/8/10 včetně Windows Mobile. Autorem programu je Sergej UA9OV a program 

lze stáhnout tady (http://www.dxsoft.com/en/products/). Aktuální plná verze je 2.37. Program je 

volně šiřitelný, ale je nutné vždy distribuovat originální archiv. Neregistrovaná verze funguje zcela bez 

problémů, má jen některá drobná omezení. 

 

Instalace 

Instalace programu je velmi jednoduchá, rozbalíme stažený archiv ve formátu .zip kamkoliv na disk a 

spustíme soubor setup.exe . Potvrdíme souhlas s licenčními podmínkami a vybereme adresář, kam má 

být program instalován. V systémech Windows 7 a vyšších doporučuji instalaci mimo adresář Program 

Files. Nyní lze již program spustit a nastavit. V případě registrace postupujte podle pokynů, které ob-

držíte spolu s registračním klíčem. 

 

Připojení zvukové karty s přijímačem 

Audio výstup přijímače by měl být propojen s lineárním nebo mikrofonním vstupem zvukové karty. Je 

velmi důležité zabránit přetížení vstupu zvukové karty. Pro snížení výstupní úrovně přijímače použijte 

externí atenuátor. Pokud překlenete předzesilovač zvukových karet, nemůžete eliminovat přetížení 

ovládacími prvky zvukové karty! Pokud je v počítači několik zvukových karet, můžete kartu vybrat po-

mocí nabídky "Setup-> Interface-> Input soundcard number". 

http://www.dxsoft.com/en/products/


 

Hodnota vzorovacího kmitočtu "Real soundcard sampling rate" na této záložce slouží k opravě chyby 

vzorkovací frekvence zvukových karet. Nominální vzorkovací frekvence je 11025 Hz. 

Ve výchozím nastavení je v mono režimu použita zvuková karta, ale možnost "Setup-> Interface-> 

Channel Input Channel" lze využít pro výběr levého nebo pravého kanálu zvukové karty. K dispozici je 

jeden ze dvou zdrojů zvuku připojených k jedné zvukové kartě. V tomto případě karta funguje v režimu 

stereo. 

Pro volbu vstupu zvukové karty (line in nebo mikrofonního vstupu) a úrovně záznamu proveďte násle-

dující kroky: 

Dvakrát klikněte na ikonu "Volume" v nabídce, pak přejděte na Option->Properties->(Recording; 

Show the following...; OK)-> ... Ujistěte se, že změníte možnosti Nahrávání, nikoliv možnosti Přehrá-

vání. Pokud znovu zvolíte úroveň nastavení vstupu, nebudete přetěžovat vstup zvukové karty. 

 

Přehled a ovládání programu 

Pracovní oblast programu je rozdělena do tří oken, jejichž velikost může uživatel změnit tažením za roh 

či hranu. 

 

V horním okně je zobrazeno aktuální spektrum signálu (modrá čára) a špičkový detektor spektrálních 

složek (zelená čára). Pravítko pod tímto oknem zobrazuje frekvence zvukového spektra. Vertikální 



červená čára v horním okně zobrazuje pracovní frekvenci filtru. Chcete-li změnit pracovní frekvenci, 

klikněte na požadovanou frekvenci (pravděpodobně na vrchol). Krátká tlustá černá čára je značkou 

frekvence TX. Používá se k nápovědě s nulovým laděním. Chcete-li změnit polohu značky TX, klikněte 

pravým tlačítkem myši na požadovanou frekvenci (nebo levým tlačítkem myši a stiskem klávesy "Ctrl"). 

Menu "Zoom" a klávesové zkratky "Alt-1" ... "Alt-7" změní frekvenční rozsah spektrogramu. Chcete-li 

přesunout viditelnou část spektrogramu doleva nebo doprava, přetáhněte ji myší se současným stisk-

nutím klávesy Alt. 

Tlačítko "AFC" nastavuje dlouhou červenou čáru (pracovní frekvenci) na nejvyšší kmitočet. Čísla vlevo 

od tlačítka AFC určují limity AFC. První číslo je lokální odchylka v Hz, tj. Maximální odchylka od aktuální 

frekvence. Druhé číslo je globální odchylka v hertzích, tj. maximální odchylka od poslední frekvence 

zvolené uživatelem. Uživatelsky zvolená frekvence je zobrazena na spektrogramu krátkou červenou 

čárou. 

Když je vybrána volba "Setup-> Interface-> AFC at mouse click", program CwGet okamžitě nastaví frek-

venci RX na nejbližší stanici po každém kliknutí myší na spektrogram bez ohledu na stav tlačítka "AFC". 

Tato akce však není provedena po kliknutí na pravítko pod spektrogramem. 

Tlačítko "GotoMax" skočí na špičkovou frekvenci v pásmovém směru. Tlačítko "AutoGTM" přepne na 

automatický režim "GotoMax". Přeskočí na špičkovou frekvenci nejsilnějšího signálu po detekci pauzy 

více než osmi "bodů" v aktuálním signálu. 

 

Režim automatického řízení kmitočtu vysílače lze zapnout pomocí nabídky "Setup->Tuning->Tune RIG 

by ". V tomto režimu se vysílací rádiová frekvence mění tak, aby obsahovala kmitočty od kmitočtu RX 

až po kmitočet TX. Automatické ladění se provádí po kliknutí na spektrogram nebo pravítko níže. Ladění 

lze provádět buď pomocí RIT nebo VFO podle zvolené možnosti. Uvědomte si, že každý transceiver 

nemá programovatelný RIT. V tomto případě není možné použít automatické ladění pomocí RIT. Ladění 

se potom provádí pomocí softwarového rozhraní Omni-Rig (http://www.dxatlas.com/omnirig/), které 

by mělo být nainstalováno samostatně. Software Hamport (http://www.dxsoft.com/en/produ-

cts/hamport/) také používá toto softwarové rozhraní a automaticky jej nainstaluje. 

Klávesová zkratka "Ctrl-U" slouží k rychlému přepnutí tohoto režimu (bez použití okna "Setup"). 

Volba "Use RIG" slouží k výběru zařízení řízeného Omni-Rig. 

Tlačítko "Show Omni-Rig Setup" slouží k aktivaci dialogu nastavení Omni-Rig. 

http://www.dxatlas.com/omnirig/
http://www.dxsoft.com/en/products/hamport/
http://www.dxsoft.com/en/products/hamport/


Volba "Use mouse wheel for tuning" umožňuje použití kolečka myši pro ladění. Je-li povoleno ladění 

transceiveru přes Omni-Rig, kolečko myši mění kmitočet vysílače, v jiném případě kolečko mění zvuko-

vou frekvenci. 

Položka "Wheel tuning speed" definuje rychlost a směr změny kmitočtu při otáčení kolečka. 

Dolní okno je oscilogram signálu. Červená vodorovná čára zobrazuje prahovou hodnotu detekce pří-

tomnosti signálu. Práh se změní myší a musí být stanoven na určité úrovni nad hlukem. Při silném 

signálu může být práh zvýšen. 

Tlačítko "AutoThr" zapne režim automatického ladění prahové hodnoty detektoru pod úrovní signálu. 

V tomto režimu jsou zobrazeny dvě vodorovné červené čáry. První řádek zobrazuje aktuální úroveň 

prahu, druhý řádek ukazuje odhad hladiny hluku. Je-li zapnuta volba "Setup->Interface->Enable ma-

nual auto-threshold limit", je úroveň rušení nastavena ručně. Tato úroveň se používá jako minimální 

úroveň prahu detektoru. 

Volba "Setup->View->Always on top" umisťuje CwGet před všechna okna. 

Varianta "Setup->View->Logarithmic spectrogram scale" nebo alternativní použití klávesové zkratky 

"Alt-Z" umožňuje přepínání mezi lineární nebo logaritmickou stupnicí. Obdobně možnost "Setup-> 

View-> Logarithmic oscillogram scale" nebo klávesová zkratka "Ctrl-Z" změní měřítko okna oscilo-

gramu. Logaritmická stupnice je obvykle pohodlnější, ale potřebuje větší nároky na počítač. 

Přijaté symboly se zobrazují v prostředním okně. Sekvence dash-dot (čárky a tečky) uzavřená v kon-

stantních závorkách znamená "špatný" symbol. Obvykle tento případ nastane, když operátor nedodr-

žuje intervaly mezi znaky a skutečně propojuje některé znaky do jednoho. Zvýšení prahu detektoru 

může lehce pomoci. 

Program CwGet automaticky definuje rychlost CW. Tlačítko "Sp.Lock" omezuje změnu rychlosti CW 

podle hodnot (v LPM) definovaných regulátory na levé straně tohoto tlačítka. Klávesová zkratka pro 

toto tlačítko je "Alt-K". Kliknutím na toto tlačítko se stisknutým tlačítkem "Ctrl" se přesune středová 

hodnota omezení rychlosti na aktuální rychlost. 

Možností "English charset", "Russian charset", "Swedish charset" a "User-defined charset" na stránce 
"Setup->Text" lze vybrat použitou abecedu. V posledním případě je znaková sada definována jedno-
duchým textovým souborem. Viz příklad v souboru SAMPLE.CWG. Musíte také zvolit vhodný skript 
písma v nabídce "Setup-> Fonts & Colors-> Rx window font". Pro běžný provoz postačí ponechat na-
stavení "English charset" – poznámka překladatele. 
 

 
 



Písmo přijatých symbolů a barvy prvků rozhraní jsou definovány na stránce "Setup->Fonts & colors". 
 

 
 

Příkazem menu "File-> Clear Buffer (Alt-D)" se vymaže okno Received Symbols (přijaté znaky). 
Příkaz "File-> Save Buffer (Ctrl-S)" uloží tento obsah okna do souboru. 
Příkaz "File-> Open Buffer in Notepad" uloží při příjmu dočasného souboru obsah vyrovnávací paměti 
do textového souboru a následně tento soubor otevře pomocí textového editoru. Poté můžete tento 
soubor zobrazit nebo vytisknout. Klávesová zkratka tohoto příkazu je "Ctrl-N". 
Soubor "File-> Open Text Capture File" otevře soubor pro zachycení přijatých symbolů. Pak jsou do 
tohoto souboru zapsány nové přijaté symboly. Pokud existuje soubor, do něj jsou doplněny nové sym-
boly. 
Příkaz "File-> Close Text Capture File" zavře soubor zachycení. Stav stavu souboru se zobrazuje ve sta-
vovém řádku. Klávesová zkratka pro příkazy pro zapnutí a vypnutí je "Alt-L". 
Argumenty příkazového řádku "/c Filename" můžete použít při spouštění programu pro současné ote-
vření souboru pro zachycení. "Filename" je název souboru, který se má otevřít. 
Příkaz "File-> Open Wave Capture File" otevře zvukový soubor pro uložení všech přijatých zvukových 
karet. Soubor je uzavřen příkazem "File-> Close Wave Capture File". Klávesová zkratka pro tyto příkazy 
je "Alt-V". Uvědomte si, že pro minutu nahrávání zvuku potřebujete více než 1 MByte místa na disku. 
 
V menu "Filters->Main Filter" vyberte šířku pásma filtru signálu. Větší šířka pásma filtru je vhodná pro 
větší rychlost. Existují dvě sady filtrů FIR a IIR. FIR filtry obvykle fungují poněkud lépe než IIR filtry, ale 
FIR filtry potřebují mnohem více času procesoru. Takže můžete preferovat filtry IIR pokud nemáte po-
čítač příliš rychlý. 
V nabídce "Filters -> Burst Filter" se vybírá maximální rychlost filtru. Dávkový (burst) filtr je odolnější 
proti filtru s krátkým šumem. Když je program detekuje přítomnost signálu, délka signálu se porovná s 
prahem. Pokud je signál kratší než prahová hodnota, je ignorován. Sériový filtr s nastavením "100 LPM" 
znamená, že prahová hodnota je asi polovina délky "dot"(tečky) při 100 LPM (20 WPM). 
 
Můžete také použít CwGet jako úzkopásmový zvukový filtr DSP. Takže CwGet vám může pomoci dekó-
dovat morse přijímanou poslechem. Šířka pásma zvukového filtru je vybrána pomocí nabídky "Filters-
>Sound Output". Zvuková karta použitá pro tento výstup s filtrem DSP je definována v menu "Setup-> 
Interface-> Output soundcard number". K výběru výstupního kanálu zvukové karty se používá volba 
"Setup-> Interface-> Output soundcard channel" (Mono/Left/Right). Pokud vaše zvuková karta pod-
poruje plně duplexní režim, může být současně použita stejná karta pro vstup a výstup zvuku. Kláve-
sová zkratka "Ctrl-F" slouží k zapnutí a vypnutí zvuku. 
 



CwGet dokáže také dekódovat signály ze zvukového souboru (soubor WAVE). Požadovaný soubor je 
vybrán příkazem "File-> Decode From File". Soubor WAVE musí být soubor Windows PCM bez kom-
prese. Preferované parametry souboru jsou mono, 16 bitů, 11025 Hz. 
 
CwGet má jeden minutový zvukový buffer. Tlačítka "Replay" a "Save" slouží k ovládání této vyrovnávací 

paměti. 

Tlačítko "Replay" způsobí přehrání předchozích 10 sekund přijatého signálu. 

Tlačítko "Save" uloží předcházejících 60 sekund zvuku do zvukového souboru v adresáři "Waves". 

 

Tento zvukový soubor je uložen s časem označeným jménem (HH_MM_SS.wav) v podadresáři s ná-

zvem označeným datem (YEAR-MM-DD). Například soubor "Waves\2004-06-03\15_10_43.wav" je 

zvuk, který začal v 15:10:43 UTC dne 03. června 2004. 

 

Příkaz "File-> Multi-Channel Decoder" otevře další okno Multi-RX. 

 

 

Toto okno obsahuje horizontální "vodopád" a text nad ním. Kliknutí myší na vodopád mění frekvenci 

hlavního dekodéru. Barvy prvků a parametrů písma tohoto okna jsou definovány na stránce "Setup-> 

Multi-decoder". 



 

 

 

CwGet dekóduje až pět nejsilnějších signálů v pásmu přibližně 2 700 Hz a zobrazí je v tomto okně. 

Chcete-li snížit množství nežádoucích signálů v tomto okně, použijte squelch. Prahová hodnota Squelch 

je zobrazena horizontální čárou v okně Spectrogram. Tuto prahovou hodnotu lze změnit myší stisknu-

tím tlačítka "Shift". 

Rozhraní "Setup-> Interface-> Enable Squelch in Main RX Window" umožňuje také squelch v hlavním 

okně RX. 

"Setup->Multi-decoder->Use manual auto-threshod limit from main decoder" z hlavního dekodéru 

umožňuje použití ručně definovaného prahového limitu v multikanálovém dekodéru. 

"Setup->Multi-decoder->Use speed limits from main decoder" definuje, zda se v okně vícenásobného 

dekodéru používají omezení rychlosti. 

Vybrané možnosti programu se ukládají prostřednictvím nabídky "Setup->Save Setup". Ve výchozím 

nastavení jsou do souboru CWGET.INI zapsány základní předvolby. Program vyhledá tento soubor v 

pracovním adresáři a pokud není soubor CWGET.INI nalezen v pracovním adresáři, pracovní adresář se 

změní na výchozí hodnotu. Pro různé situace můžete mít několik variant ini souboru. Stačí vytvořit 

několik zkratek pro CWGET.EXE každý s jiným pracovním adresářem a kopírovat soubor CWGET.INI do 

každého z těchto adresářů. Další možností je definovat název konfiguračního souboru v příkazovém 

řádku po / F, například CwGet.exe /F C:\MyData\cwget2.ini. Pokud je k dispozici tlačítko /F a nezmění 

se pracovní adresář. Upozorňujeme, že pokud není po klepnutí / F k dispozici úplná cesta k souboru, je 

pro čtení a zápis ini souboru použit defaultní adresář Windows. 

Program může přenášet přijatá data do staničního deníku AALog. Chcete-li přenést data z okna RX, 

poklepejte na slovo nebo vyberte slova myší. Poté vyberte pole z rozbalovací nabídky. CwGet odstraní 

všechny mezery v textu přeneseném do deníku. 

Když je zapnuta možnost "Setup-> Text-> Catch word by one mouse click", můžete zachytit slovo z 

okna RX jediným kliknutím myši, nikoli dvojitým kliknutím, ale stále můžete vybrat část textu myší ta-

žení. 

Když je zapnuta volba "Setup-> Text-> catch words in contest mode", program nepoužívá vyskakovací 

menu pro záznam slov do deníku. V tomto případě CwGet automaticky rozpozná volací znak nebo řídící 

kód. 



 

 Když je zapnuta možnost "Setup-> Text-> Copy transferred data to clipboard", data přenesená do 

protokolu jsou také zkopírována do schránky Windows. 

Číslo zobrazené v poli "FrB" stavového řádku znamená počet volných vyrovnávacích pamětí pro záznam 

signálu. Pokud je snížena na deset nebo méně, rychlost počítače nedostačuje. Zkuste snížit počet sou-

časně spuštěných programů nebo použít jiný počítač. 

CwGet přenáší některé horké klávesy do programů CwType, pokud je používáte. Není tedy třeba příliš 

často přepínat mezi okny CwGet a CwType. 

Rozhraní CwGet se softwarem pro záznam a protokolem CwType prostřednictvím zpráv ini a souborů 

Windows. Volba "Setup/Interface/Messages  channel" může být použita k oddělení řízení několika 

spuštěných instancí CwGet. 

CwGet lze použít také jako COM-server (objekt ActiveX). 

CwGet také může přenést přijaté znaky do jiného softwaru knihovnou DXSOFTEX.DLL. Volba "Setup/In-

terface/Exchange DLL channel" volí použitý kanál DXSOFTEX.DLL. Výchozí hodnota je 1. Podrobnosti o 

spolupráci programů naleznete na adrese http://www.dxsoft.com/dxs-exch.zip . 
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